Blog do TaQ

Estou usando o X.Org!

Publicado em GNU/Linux

A curiosidade matou o gato, mas resolvi arriscar. Os pacotes do X.Org foram liberados no current do Slackware e eu resolvi já adiantar a coisa e instalar para ver qual era.
Antescolhi comentários da galera, que foram desde uma reinstalação total do sistema (não entendi direito por que, mas tudo bem) até uma instalação muito fácil em 5 minutos. Lá vou eu meter a mão na massa.
Antes de mais nada, backups! Fiz um backup do meu /etc/X11/XF86Config, mesmo com todo mundo jurando de pé junto que não daria nada.
Desinstalei todos os pacotes do XFree86, instalei os do X.Org e ... startx. Tela estranha. Cadê o logotipo da Nvidia? Que raios de resolução tosca é essa, e cadê o topo das janelas? Raios.
Ok, nada de pânico. Peraí, o console está com fontes pretas em tudo quanto é lado! Agora pode começar o pânico! Vixi, o que rola? O vi tá medonho! Calma.
Vou rodar o xorgconfig para ver o que rola. Pego os parametros do XF86Config e termino a configuração.
O console continua doidão. Por que diabos o servidor gráfico influencia nisso? Será alguma coisa do framebuffer (eu desliguei!)?
Na pressa de não ter que descobrir que serviço reiniciar, eu dou um reboot. Voltou tudo normal! Legal.
startx. Opa! Resolução legal! Abro um terminal e a tecla / não funciona. Dou um ls para lembrar o arquivo de configuração (.Xmodmap) e esqueço do less, subo a tela com a rodinha do mouse e ... a rodinha não funciona.
Ok, abro o XF86Config anterior e insiro a configuração do teclado anterior, a do mouse, e troco o driver da placa de vídeo de nv para nvidia, insiro o glx no Modules, fecho o servidor gráfico, abro de novo e voilá! Logo da Nvidia no ínicio, teclas funcionando perfeitas e rodinha do mouse subindo e descendo.
Até que não foi traumático. Pode ser que eu levei sorte, mas para descobrir isso, você precisa instalar o bicho. Boa sorte!
Tags:


Comentários

Sem nenhum comentário.

comments powered by Disqus

Twitter